Need assitance with installation on Ubuntu on Windows

Hello TigerGraph Team members:

I am a novice in TigerGraph and I am just learning to use it from scratch now. Unfortunately, I can not get through the installation procedures. I am trying to install version 3.1.0-offline on Ubuntu on Windows. That is, Ubuntu installed in Windows that has identical interfaces as a real Ubuntu shell. By running ./ or sudo ./ and using default configurations

The default user who will own and run TigerGraph platform: tigergraph.
The default TigerGraph user’s password: tigergraph.
The default AppRoot of TigerGraph platform: /home/tigergraph/tigergraph/app.
The default DataRoot of TigerGraph platform: /home/tigergraph/tigergraph/data.
The default LogRoot of TigerGraph platform: /home/tigergraph/tigergraph/log.
The default TempRoot of TigerGraph platform: /home/tigergraph/tigergraph/tmp.
The default ssh port used in TigerGraph platform: 22.
Please enter the number of node(s) that the TigerGrpah platform will be installed on (e.g. 3): 1
The default ip address of single node installation:

I was always able to install it but starting tigergraph service always threw me an error. The error was

ExternalError (Failed to start executor(s); Failed to ssh to with given credential; dial tcp connect: connection refused.

In order to preclude networking issues, I manually deactivate all Windows Firewalls. Thanks!

Servus @Muenchen,

can you please check if SSH is running under Ubuntu?
sudo service ssh status


Thanks, Bruno. I followed your advice and made several changes to the configuration file.

sudo vi /etc/ssh/sshd_config

PermitRootLogin yes
PasswordAuthentication yes
AllowUsers root

and then restarted SSH with

sudo /etc/init.d/ssh restart

this time when running the command you mentioned, it output

* sshd is running

I explicitly tested the connectivity of SSH over port 22, and it seemed OK

sudo ssh -p 22 root@

Still, while installing tigergraph was successful, I got an error when the computer was doing

Start tigergraph service, this may take a while …

The error message looked like

[ Info] Starting EXE
[ Error] ExternalError (Failed to start executor(s); Failed to ssh to with given credential; ssh: handshake failed: ssh: unable to authenticate, attempted methods [none publickey], no supported methods remain)

Can you give me some hints on that?

You need to enable acces for user tigergraph.
This was the user you used for the installation (please check your install settings!)

If you can login with

sudo ssh -p 22 tigergraph@ then TG server should start without problems.


Thank you, Bruno. It works indeed. Besides, the default password for user tigergraph is also tigergraph.