How to change the port of admin (default 14240) to 80?

Version: Developer Edition

I followed the instructions of TigerGraph Docs: admin faqs.

The default port for the GraphStudio UI is 14240. (Prior to TigerGraph 1.2, it was 44240.) Use the following to check its configuration:

gadmin --dump-config |grep gstudio.web.port

and found nothing

In my system, there are only these ports as follows:
[tigergraph]$ gadmin --dump-config | grep port

admin.port: 12471

admin.portal.websocket.private_port: 14243

dictserver.base_ports: '17797'

gpe.base_port: 7500

gse.base_port: 6500

gse.rls_port: 8900

gsql.server.private_port: 8123

gstudio.web.private_port: 14242

gstudio.websocket.private_port: 14241

ha.virtual_port: 9001

kafka-loader.base_port: 9500

kafka.port: 30002

nginx.port: 9000 14240

redis.port: 6379

restpp-loader.base_port: 8500

restpp.base_port: 5500

restpp.http.port: 10000

restpp.port: 9000

security.ldap.port: 389

ssh.port: 22

zk.port: 19999

So, I changed the to 80 via gadmin --configure port and gadmin config-apply to apply it. Then restart: gadmin restart -fy

It did not work!


On most Linux system, using ports under 1024 requires root privilege. Since TigerGraph is not run under root privilege, you cannot specify any port under 1024.

To use 80 port, you may use port forwarding: run a proxy application with root privilege and forward all traffic from 80 to 14240. Nginx is one option and you can refer to the config file of tigergraph internal nginx:


At your own risk, you can use iptables (will need to be run as root, and will not persist after a reboot):

sudo sysctl -w net.ipv4.ip_forward=1
sudo iptables -t nat -A OUTPUT -o lo -p tcp --dport 80 -j REDIRECT --to-port 14240
sudo iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to-ports 14240