GSQL webclient on TGCloud doesnt launch in Firefox

I am trying to launch the GSQL web shell

on my TGCloud instance via Firefox browser. For some reason, it doesn’t simply come up and gives me a blank page. Please see attached.

When i try to do the same in another browser, the web shell comes up fine.

is this a known issue with Firefox? are there any special settings on the browser what twill enable the GSQL web shell to work properly ?

I just tried it on a fresh install of FireFox and it worked fine for me.

Try visiting the link without the port number attached to the end, like this:

I’ve experienced the same with Firefox and the GSQL webclient. After I take a look in the console via developer tools, here’s the error message I see:
Loading failed for the with source “”.

My guess would be that something the javascript file relies on isn’t compatible with Firefox.

My personal workaround has been to use Chrome for GSQL client access.

I’ve opened up a ticket with the Cloud Engineering team, but given that there is a straight forward workaround I imagine this will be low priority.

1 Like