Generate a token from a secret does not work on tgcloud

I am using a new blank instance on TigerGraph Cloud and I am following the directions here to generate a token from a secret:

The curl request never returns or times out.

Any suggestions? I have generated multiple secrets using the Admin interface and I have tried reading the secret from a file and as a parameter. All these methods fail.


As of three days ago, all new TG Cloud solutions’ endpoints redirect to :443 or :443/restpp.

Here’s a sample request to generate a new token:

curl -X POST -d '{"secret": "secret_string", "lifetime": "100000"}'

You can read more about this on the note in the updated documentation page.

Note for users of TigerGraph Cloud

For all TigerGraph Cloud solutions created on or after June 20, 2022, ports 14240 and 9000 are no longer exposed. This also applies to previously created cloud solutions that are resized on or after June 20, 2022. Use port 443 instead for API endpoint connectivity on cloud solutions:

  • Use API endpoint 443/restpp/<endpoint> for RESTPP endpoints that were on port 9000
  • Use API endpoint 443/<endpoint> for endpoints that were on port 14240

For all TigerGraph Server solutions not on TigerGraph Cloud, or for TigerGraph Cloud solutions created before June 20, 2022, ports 9000 and 14240 remain correct.

1 Like

That worked! Thanks!!!


Hi Shreya - we can now get most of the REST endpoints to work, but I can get echo or list-endpoints to work with the new URL rewrite rules. Do you have samples of these working on TigerGraph cloud?

Happy Friday! - Dan

I got everything working now. I just put the authorization token in my ~/.curlrc file and the following works fine:

curl -X GET
curl -X GET

I forgot to remove the /query/ in the URL!


In GraphStudio the “link” in the toolbar in the GSQL editor still shows the old ports:

Here is what it says when I click on the default “hello” query: