Error starting ZK when running the command "gadmin start infra"

Hello TG team members:

Good day!

I am encountering errors when running the command gadmin start infra. The error output was like

tigergraph@LAPTOP-BFD2CE3C:~$ gadmin start infra
[Warning] ParameterErr (License has not been set, or not applied yet)
[ Info] Starting EXE
[ Info] Starting CTRL
[ Info] Starting ZK KAFKA IFM ETCD
[ Error] Timeout (failed to start ZK#1 by grpc; Timeout(1m0s) when Waiting executable ZK#1:check_ready to finish)

Initially, I ran into the problem of being unable to start Kafka. As per @Bruno_Simic and his replies to a similar issue (timeout when starting Kafka), I followed similar steps and solved it. That is, renaming the file folder for Kafka to something else.

My file folder directory is quite different from what was in the post above (timeout when starting Kafka),

tigergraph@LAPTOP-BFD2CE3C:~/tigergraph$ pwd
/home/tigergraph/tigergraph

and the folders are

tigergraph@LAPTOP-BFD2CE3C:~/tigergraph$ ls
app data log tmp

and the Kafka folder is in /home/tigergraph/tigergraph/log

tigergraph@LAPTOP-BFD2CE3C:~/tigergraph/log$ ls
admin dict executor gse gui kafka kafka_old nginx ts3 zk controller etcd gpe gsql informant kafkaconn kafkastrm-ll restpp ts3serv zk_old

where I renamed kafka to kafka_old and a new kafka folder was created by TigerGraph.

Still, I was not able to start ZK and failed to solve the problem with similar steps. I renamed zk to zk_old and a new zk folder wad created by TigerGraph. However, the problem was not solved.

I am using the same OS, i.e. Ubuntu 18 Windows Subsystem for Linux on Windows 10.

@Muenchen what TG version are you using?
If you don’t have any data in the /data folder i would suggest to rename the whole folder (after stopping TG with gadmin stop) and to restart it.