Endpoint is not found from url = /gsql/schema

I’m trying to get the schema using an example from pyTigerGraph but get the error:

“Endpoint is not found from url = /gsqlserver/gsql/schema”

My full url is:


and I tried using token authentication which I have done many times successfully calling other endpoints. I know there are some restrictions on schema related things but i thought those were for modifying the schema, not getting schema info. but just incase, I also tried user name/password authentication.

However, I have never tried username/password authentication so maybe I’m doing that wrong. Note, both times i did not get the error Access Denied…

Note: when I call this to get endpoints:

I get a long list of endpoints but nothing with the word schema.

Can anyone make a recommendation here?

Thank you.

Hi George,

The /gsqlserver/gsql/schema endpoint is actually not provided by the REST++ API, but by the GSQL Server API, and that is accessible via port 14240 (and not port 9000, and not even port 8123 which is an incorrect information in the documentation, to be corrected soon). Just change to port and it will work.

In short, if an endpoint URL contains “gsqlserver”, the port to be used is 14240.

And since this end point (and also /gsqlserver/gsql/udtlist and /gsqlserver/interpreted_query) are not provided by the REST++ API, they won’t be listed among the endpoints by /endpoints.