Delayed response from TG-Cloud

I’m successfully sending http requests to tg-cloud, but response time is extremely high.
A simple request to invoke a query that returns a single vertex as json by its key (the ONLY vertex in the graph DB) takes 2441 ms from either an AWS Cloud9 Terminal or a small Python test program from my machine.
Running the query from TG-Studio seems to be quick enough.
Is this because I’m using the free tg-cloud tier?
Any pointers what can I do to sort it out?

Free tier should not mean any slower communication over the network. I am not aware of any restrictions or limitations, and I have never experienced long response times although I use TigerGraph Cloud instances often to work (e.g. on pyTigerGraph code, which works over HTTPS).

Could you try tracert to see where is the time spent in network communication?

Thanks, Szilard.
I don’t know how to work with tracert.
I tried running tracert as per their docs and example, but received an error:

Unable to resolve target system name c:/Users/morsa/Documents/IDrive-Sync/Dev Env/Projects/SkillBlaster/tg-test/virtual/Scripts/python.exe.

This is what I submitted:

tracert "c:/Users/morsa/Documents/IDrive-Sync/Dev Env/Projects/SkillBlaster/tg-test/virtual/Scripts/python.exe" "c:/Users/morsa/Documents/IDrive-Sync/Dev Env/Projects/SkillBlaster/tg-test/"

I’m running this in VSCode Terminal.

The same command without the “tracert” works fine.


Hi Mor,

tracert traces the network path from your computer to a network address. It requires an IP address or host name. So it needs to be executed something like this:


It shows the various network points (routers, switches, etc.) between you and your target, and shows how long it takes to get there. It can reveal where most of the time is spent in the network communication.

For more details visit

Yes, Szilard.
I am able to run:
But when I run:
tracert https://************

I get this error:
Unable to resolve target system name

I can invoke this URL directly in the browser with good response.