Backup issues to s3

Hi, we are having some troubles backing up our tg db to a S3 bucket.

It first hangs at:

2019/08/08 08:23:24.304953 INFO Deal with client backup request, tag 20190808-001
2019/08/08 08:23:25.089954 INFO Running bootstrap…
[08:23:25] Start workgroup
2019/08/08 08:23:25.090001 INFO chdir /home/tigergraph/tigergraph/bin

gbar list shows the following error:

tigergraph@tg11:~$ gbar list
[09:18:45] Retrieve TigerGraph system configuration
[09:18:53] Start workgroup
[09:19:02] Terminate workgroup
Fail on list, Fail to prepare GBAR work dir /home/tigergraph/tigergraph/gstore/gbar, Fail to post data to, Post dial tcp getsockopt: connection refused

gadmin status:

tigergraph@tg11:~$ gadmin status
=== zk ===
[SUMMARY][ZK] process is up
[SUMMARY][ZK] /home/tigergraph/tigergraph/zk is ready
=== kafka ===
[SUMMARY][KAFKA] process is up
[SUMMARY][KAFKA] queue is ready
=== gse ===
[SUMMARY][GSE] process is up
[SUMMARY][GSE] id service has NOT been initialized (online online online)

could it be a problem that the GSE id is not started? We tried gadmin restart gpe on m1 but the GSE id is still not initialised.

Tg version - 2.2, 3 replicas, 1 partition.