Azure VM: gadmin command not found

I have used the TigerGraph 3.5.1 template from Azure Marketplace to deploy a VM (and supporting resources). When attempting to run gadmin status command, I receive a command not found error. Can anyone provide some guidance on how to fix this?

Hi @bnsmith Can you provide me which options you choose? I will replicate the steps you took to see if I’m running into the same issues.

Greetings and thank you Jon! I followed the directions listed here: Get Started on Microsoft Azure :: Docs. I selected v3.5.1 with Standard E4s v3 (4 vcpus, 32 GiB memory) instance.

@bnsmith I’ll run through this as well to test it out.

Can you confirm you are running the gadmin command on the user account that was created when installing. I do see you’re specifying -u, but could you log into that users account and run gadmin status Thanks!

I cannot log in. I’m having another issue with the VM where I cannot SSH in to it. The best I can do right now is use sudo to run commands as a user (unless you know of another way).

I have confirmed that if I run sudo -u tigergraph whoami that it returns tigergraph; not sure if that is good enough though.

Any update on this @Jon_Herke?

@bnsmith I’ll ask the TigerGraph Cloud Vendor internal team. For some odd reason I cannot select a VM configuration. It’s all grayed out.

Hi @bnsmith,

It looks like sudo isn’t picking up the updated user path for tigergraph, something I was able to reproduce as well in a cloud instance on my side. I saw you mentioned getting SSH working, I would focus on that as it will be much easier to create a deployment with an interactive terminal. I have a few other possible recommendations:

  1. We offer free instances for testing up to 50G (~10G data can be uploaded without filling up the disk) on You can select to have it hosted on Azure, and even set up VPC peering to current environment(s).
  2. You can install an on-prem instance where ever you’d like. These are free up to 50G of compressed graph. Get TigerGraph - TigerGraph



I’ve confirmed that, after using an actual SSH client and switching user context, the gadmin command works as expected. Thanks for the help!

1 Like

@bnsmith Glad the worked!! Let us know if you run into any more issues! Always happy to help :slightly_smiling_face: