Algo Loader: AuthenticationFailedException: Invalid Username/Password!

I am trying to use the Algo Loader for the first time and the above error appears everytime I try to run the code.

Since I am using the free version of TG cloud to prepare for the certification, I do not get any password while creating the instance for the solution. Therefore, I tried different combination of username and password including the one I used first to create the account.

I also tried to remove this info from the code completely but it did not work either.

Hey, @absamsyed!

As of July 6th, your username will be __GSQL__SECRET and your password will be a secret you generate. Here is a quick tutorial on how to generate a secret in TigerGraph Cloud. You can find this update in TigerGraph’s Release Notes.

  • Username/password authentication has changed for connectors to TigerGraph Cloud instances.
    • Users need to create a secret in the Admin Portal UI.
    • Secrets can only be created through the GUI after a graph has been created.
    • When entering the credentials, the username needs to be __GSQL__SECRET, and the password needs to be the secret.
1 Like

@absamsyed Do you have a link to the “Algo Loader” you’re mentioning? I would replicate the process you’re going through.

1 Like

Hi @Shreya_Chaudhary, thank you for your response. I am still getting the same error despite implementing your suggestion. I am using __GSQL__SECRET as a username and secret value generated automatically after creating the Secret Alias in the Admin Portal.

Hi @Jon_Herke
here’s the link: ecosys/AlgoLoader.ipynb at master · tigergraph/ecosys · GitHub

@absamsyed I see the last edit to that was about 2 years ago. I just went through it as well and noticed that the file structure of the Algorithm library was changed.

If you’re using 3.6 of TigerGraph - GraphStudio has the ability to install algorithms directly. Would this option work for you?

Click Choose from library

Choose Algorithm you would like to install


Hi, I have same issue. I try to create graph with pytigergraph. Due to last update, my solution was created few day ago so I added new username-password pair with Access managment tab but still i can’t run my script successfully becous have “invalid username/password”. Version of pytg - 1.0.2 (lastest)

Hi @SidelMeril I ran into a similar issue. The resolution to my issue was I needed to assign roles the newly created user permissions. When you go to role management can you confirm you have a role assigned?

1 Like

Hi, Jon, I have updated my new user with superuser role but still have same issue. I added new one user but I can’t find checkbox for it and global graph disappered from the menu.

@SidelMeril Just to confirm you can see your graph name, but not global? So you cannot select “Global” and “Superuser”, then check your “user” and “save”?

Graph & Roles:

Graph Options:

Yas, Jon, I can’t

but it disappared when i set ‘superuser’ role